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Question 1
 
(a) Define information transmission.
(b)        D ifferentiate between:

1. Internet and intranet;
2. LAN and WAN.
(c)        List four devices used in a LAN environment.
 

Observation
  
The question tested the knowledge of the candidates in the definition of information
transmission and networking terms. The Chief \examiner reported that most of the
candidates were able to give the definition of the terms listed. 
The expected answer is:

Definition of information transmission
Information transmission is the act of sending and receiving/ transfer of/ exchange of 
information/ message from one a person/place to another through a medium
OR
Information transmission is the exchange of information in any form (voice, data, text
and images) from a sender to a receiver(s) over a medium (air, cable, water, etc )
using natural, or man-made equipment or tools.

Difference between:
Internet and Intranet

Internet Intranet
A network of computers connected
globally

A computer networks within an
organization

A public network A private network
Network of networks A single network
Information is broad and unlimited Information is limited to the

organisation’s needs
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Internet is not owned by anyone Intranet is owned by an organisation
It can be accessed by anyone It can only be accessed by employees

and members of the organisation
It is less secured and not safe It is often firewalled, restricted and

considered secured and safe
Unlimited number of users Has limited number of users as

designed by the organisation
Support various services and protocols
such as; http, ftp, smtp, gopher,
telnet, irc,

Support limited services of the
organisation, such as collaboration,
shared calendar, training, Video and
Audio Conferencing

High network traffic Low network traffic
LAN and WAN

Local Area Network (LAN) is a network of computers that covers a small
geographical area while Wide Area Network (WAN) is a network that spans a large
geographical location across states, regions and continents.

Devices used in a LAN environment
Hub
Switch
Server
Bridge
Connectors
Bluetooth Radio
Wireless Adapters
Routers
Repeater
LAN Card/ NIC (Network Interface Card)
LAN Extender
Access points
Printer
Smart Devices
Mobile Phone
Scanner
Digital camera
Workstation/Computer/ Laptop/Desktop
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Question 2
 
A medium scale enterprise intends to create a database to manage its staff records
with the following fields: staff ID, Name, Address, Photograph and Department.

1.  (i) What is a Database?
                                                                                    
(ii)  List three DBMS the firm can use to achieve the stated objectives.

1.   (i)   Mention two tasks that can be performed on staff photographs using graphic
packages.

                                                                                  
(ii)  Give three examples of graphic packages that can be used for the tasks in 2 (b)
(i)

Observation
                                                         
The question tested the candidates’ skill in DBMS.
The Chief Examiner reported that a good number of the candidates who attempted
this     question struggled with the task.
 
 The expected answer is:
(a) (i)   A database is an organized collection of data or information electronically for
easy access and management
OR
Database is a collection of information that is organized so that it can easily be
accessed, managed and updated.         
OR
A database is an organized collection of structured information, or data, typically
stored electronically in a computer system.
OR
A database refers to a collection of logically related information organized so that it
can be easily accessible, managed and updated.                                           
                                                                                                                 
                  (ii) Examples of DBMS
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1. MySQL
2. Microsoft Access
3. SQL Wizard
4. Microsoft SQL Server
5. Oracle
6. RDBMS
7. dBASE
8. Fox Pro
9. PostgreSQL

10. MongoDb
11. Teradata         
12. IBM DB2
13. Informix         

SAP ASE/SYBASE  
1. amazon’s simple db   
2. Filemaker        
3. Adabas
4. SQLite
5. Toad   
6. phpMyAdmin
7. CouchdB
8. Redis
9. IBM DB2

10. IBM Lotus Approach
11. Lotus Note
12. Bigtable

Cloud Spanner
 (b) (i)  Tasks performed using graphic packages

Resize
Photo manipulation
Rotate
Mirroring
Crop
Remove background
Edit
Apply artistic effects
Contrast/Brightness  Adjustment
Blurring
Filtering
Add effects
Photo enhancement
Transparency
Flip
Change to 3D
Adding watermarks                                      

    (ii) Examples of graphic packages

Print Artist
Corel Paint/
Paint PRO
CorelDraw
Instant Artist
Harvard Graphics
Photoshop
Logo Graphics
Animation software
Print
Computer Aided Design
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Canva 
Gimp
Pixlr                
Inkscape         
MsPaint          
photoscape     
Adobe Dreamweaver
Adobe illustrator        
Adobe photoshop
SumoPaint
Blender
Sketch
Mega Creator

Logic Graphics
Affinity Designer
Adobe Indesign
VisMe
SVG-edit
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Question 3
 
(a)  (i)  What is a presentation package?                            
           (ii)   Give two examples of presentation
package.                                                                           
      (iii)  State three features of a presentation package.                 

1. Highlight the steps followed to find and replace data in MS Excel.

Observation
 
The question tested the candidates’ knowledge of presentation package. However, it
was reported that most of the candidates who attempted this question performed
relatively well.
The expected answer is:
(a)(i) Definition of presentation package
A Presentation package is a software used to display information in form of slide
show.
OR
A Presentation package is a software program with the ability to add charts, graphic,
sound, images, and videos to communicate visually with audience
            (ii) Examples of presentation package

Ms PowerPoint
Apple Keynote
Corel presentations
IBM Lotus Freelance  Graphics
SoftMaker
Slide beans        
Renderforest
Sklides
Google Slide
HAIKU DECK
Slide dog
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Prezi                  
Macromedia flash         
Legend
Windows Movie Maker
Open office impress
Canva    
Corel RAVE     

Libre office Impress     
      
(iii) Features of a presentation package

-    Slide creation
-    Adding Animation
-    Insert Chart/Shapes
-    Adding Macros
-    Adding Narration
-    Slide transition
-    Automate presentation
-    Recording
-    Formatting slides, texts and graphics
-    Slide manipulation (Copy/Paste/Duplicate)
-    Slide show                                
-    Timing of presentation
-    Text, sound, graphics, and video insertion
      
(b) Steps to find and replace data in MS Excel
-    Type Ctrl+F while the worksheet is opened
-    Type what to find in the” Search for what” text box/ what to replace with, in the
“Replace      with what” text box
-    Click on Replace/Replace All                                                                
OR
-    Click on find and select button on the Home Tab and select Find from the Drop
Down menu
-    Type what to find in the” Search for what” text box/ what to replace with, in the
“Replace with what” text box
-    Click on Replace/Replace All                                                                  
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Question 4
 
 A professional photographer uses analogue cameras and a computer system for his
business. The computer is used to prepare documents and keep records of clients’
accounts. Copies of these documents are stored in CD-ROMs and Floppy disks. The
photographer now plans to innovate by using digital cameras and the computer for
taking, editing and printing photographs.

1.  State two hardware changes required on the photographer’s computer to achieve the
planned innovation.

2. Give one reason:
3. for each of the changes in 4(a).
4. why the photographer should use external hard disk instead of floppy disk to store

data.
(c)    State two advantages of switching from analogue to digital camera.

Observation
 
The question tested the candidates’ knowledge on computer application as it applies
to real life situation. It was reported that most of the candidates who attempted this
question demonstrated poor knowledge of computer application to solve real life
problems.
   The expected answer is:
(a) Hardware changes on the photographer’s computer to achieve the planned
innovation
-    Hard Disk size
-    Higher processor/ processor speed
-    Increase RAM size
-    Install Graphic Adaptor/Card
-    Digital Camera
-    Printer
-    Multiport Adapter
-    DVD writer/Drive
-    Docking port / USB cable interface for the camera
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-    Card Reader
-    SD Card
-    Monitor with higher resolution.  
          (b)(i) Reasons for the changes
-    Increase hard device size will accommodate more storage capacity.
-    A higher processor will ensure efficiency in processing of tasks
-    Increased RAM size will improve performance of the computer.
-    Docking point/ USB cable interface/ Multiport Adapter for the camera will ensure
easy transfer of images from the camera to the computer.
-    Increased monitor resolution will enable the photographers to properly edit the
images and give a good output
-    Graphic adaptor to connect graphic display to enhance the graphical capabilities of
the system.
-    Printer to print copies of photographs.
-    Card Reader to transfer photographs to and from SD Card to the computer/camera
-    DVD writer/Drive to transfer photographs to CD-ROM
(b) (ii) Reasons for using external hard disk
-    More durable
-    More Storage Space/ Capacity
-    Usable on Multimedia devices
-    Faster access time
-    Robust storage media    
                                                                                                               
          (c)  Advantages of switching from analogue to digital camera

Better resolution
Faster processing
Long term cost effectiveness
Instantaneous satisfactory
Multiple functions
Video camera
Easy to share
Smaller and lighter
Easy editing
Massive storage space for photos

                                                   
          
         

  Prev   Next  

Copyright © 2018. The West African Examinations Council. All rights reserved.
Powered by Sidmach Technologies (Nigeria) Limited.

6/18/24, 11:04 AM Data Processing Paper 2, WASSCE (SC), 2022

https://www.waeconline.org.ng/e-learning/DataProcessing/Datap235mq4.html 2/2



Menu
General Comments

Weakness/Remedies

Candidate's Strength

Question 5
 
A class captain was asked to create a database in MS Access for all the student in
the class without using any template and name it Student_Record. The table created
is to be named Students and should have five columns/fields with the following
names:
ID_Number
Full Name
Date of Birth
Age
Home_Address

1.  Highlight the procedures the captain will follow to create the database.
2.  List the step the captain would take to create the table in Design View.  
3.  Give the data type suitable for each column/field provided.          
4.  Which field can be used as the primary key?                                   
5.  Mention one importance of primary keys.                                     
6.   List three SQL command statements the class captain can perform on the

database.                                                                                       
7.   Give the SQL query the captain will use to display all the columns in table

Students.                                                                                                  

Observation
 
The question tested candidates’ skills on database management system.
The Chief Examiner reported that candidates’ responses in this question revealed
poor practical skills in DBMS among majority of those who attempted the question.
The expected answer is:
(a)  Procedures for creating database

Open the MS Access
On the File tab/Office button, click New and then click Blank Database
Type “Student_Record” in the file name box
 Click Create            

OR
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Open the MS Access
Click Blank desktop database
Type “Student_Record” in the file name box
Click Create

                                                                                     
(b) Steps for creating the table in Design view

Click on “Create” on the Menu bar
Click on “Table Design”
Type the field name and select appropriate data type
 Save the table as Students.                                                        

OR
Click on “create table” in design view
Click on design view icon on the menu bar.
Type the field name and select appropriate data type
Save the table as Students                                                            

OR
Double click on “create table ”in design view                                       
Type the field name and select appropriate data type                                        
Save the table as Students.                                                                             

 
(c) Data types suitable for the columns/fields provided     
ID- Number ---------- Number/ Auto Number
Full Name ----------------Text/ Short Text
Date of Birth -------------Date/ Time
Age ----------------------- Number
Home Address ----------- Long Text/Memo                                                
(d) Importance of primary key
ID- Number field can be used as primary key                                            
(e) Field used as primary key
-    It is used for secondary index
-    It uniquely identifies a record in a database
-    It stands as a common link between two or more tables in relational database.
-    It cannot contain Null value
-    Values in the primary key field cannot be duplicated
(f) SQL command statements that could be performed on the database

SELECT
UPDATE
INSERT
APPEND/ INSERT INTO
DELETE 
CREATE DATABASE 
INNER JOIN
ALTER DATABASE 
CREATE TABLE 
ALTER TABLE 
DROP TABLE 
CREATE INDEX 
DROP INDEX 

(g) SQL Query used to display all the columns in table Students
SELECT * from Students                                                                        
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Question 6
 
(a) Outline the steps taken in MS word to:
(i)     create a table with 4 columns and 6
rows;                                                                                                                                                                                           
                                                                                                              
(ii)  insert a hyperlink on a text.
 
                                    
Figure 1 is a portion of Microsoft Word interface. Use the figure to answer question
6(b).    

 

Observation
 

This question also tested candidates’ skills in using Microsoft Word for data
processing. It was reported that though most of the candidates showed poor skill in
Microsoft Word.
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The expected answer is:
(b)  State the function of the parts labelled I to V in Figure 1.
  The expected answer is:
   (a) (i) Steps in creating a table
-    Click on the “Insert” tab
-    Click on “Table”
-    Click on “Insert Table”
-    Type in 4 in the “Number of columns” and 6 in the “Number of Rows” Text boxes
respectively 
-    Click on Ok.                                                              
OR
-    Click on the “Insert” tab                                                                                
-    Click on “Table”                                                                                            
-    Hover the mouse to select 4 columns and 6 rows on the displayed grids     
-    Click/ Press Enter on the keyboard                                                               

OR
-   Click on the “Insert” tab                                                                    
-   Click on “Table”                                                                                            
-   Click on “Draw Table”                                                                                  
- Use the pencil tool to draw 4 columns and 6 rows                                        
(ii) Inserting a hyperlink on the text
-Select the text
-Click on the “Insert” tab/ Right Click
-Click on hyperlinks
-Type in the link address in the “Address” box
-Click on Ok
(b)  Functions of the labelled parts
I.      Left aligned: This is used to line up text with left margin.
II.      Center: This makes a text to appear in the middle of the line.
III.    Right-aligned: This is used to line up text with the right margin
IV.    Justified; This is used to align text both left and right such that the text is
stretched across the page possibly with more than one space between words.
V.       Line spacing: This is used to select the length of space between lines of text. 
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